re = /<a.*href\s{0,}=\s{0,}".*_.*".*>(.*)<\/a>/
str = 'deepak<a href="cc">deepak</a>sharma<a href="http://deepak.sharma-sharma.com">deepak</a> sharm <a href="http://deepak.sharma_sharma.com">deepak</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end