import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*href\\s{0,}=\\s{0,}\".*_.*\".*>(.*)<\\/a>";
final String string = "deepak<a href=\"cc\">deepak</a>sharma<a href=\"http://deepak.sharma-sharma.com\">deepak</a> sharm <a href=\"http://deepak.sharma_sharma.com\">deepak</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}