# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\|MIGRATE\|)/$1;|MIG_IN|/g;t' <<< "|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U"