using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\|MIGRATE\|)";
string substitution = @"$1;|MIG_IN|";
string input = @"|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}