const regex = /^(\|MIGRATE\|)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\|MIGRATE\\|)', 'g')
const str = `|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U`;
const subst = `$1;|MIG_IN|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);