use strict;
my $str = '|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U';
my $regex = qr/^(\|MIGRATE\|)/p;
my $subst = '$1;|MIG_IN|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";