re = /^(\|MIGRATE\|)/
str = '|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U'
subst = '$1;|MIG_IN|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result