#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\|MIGRATE\|)"
Local $sString = "|MIGRATE|;|10000|;|2ACC0003|;|30/09/13|;|Positive Adjmt.|;||;|MIGRATE|;|95004U"
Local $sSubst = "$1;|MIG_IN|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)