#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([()-]|\d+)"
Local $sString = "(123-456)-12-1"
Local $sSubst = "hit!"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)