// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([()-]|\d+)").unwrap();
let string = "(123-456)-12-1";
let substitution = "hit!";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}