$re = '/([()-]|\d+)/';
$str = '(123-456)-12-1';
$subst = "hit!";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;