import re
regex = re.compile(r"([()-]|\d+)")
test_str = "(123-456)-12-1"
subst = "hit!"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)