using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([()-]|\d+)";
string substitution = @"hit!";
string input = @"(123-456)-12-1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}