use strict;
my $str = '(123-456)-12-1';
my $regex = qr/([()-]|\d+)/p;
my $subst = 'hit!';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";