#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "."
Local $sString = "" & @CRLF & _
"For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression" & @CRLF & _
"" & @CRLF & _
"For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/" & @CRLF & _
"" & @CRLF & _
"For a gentle tutorial introduction to RegExes, see http://regexone.com/" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")