use strict;
my $str = '
For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression
For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/
For a gentle tutorial introduction to RegExes, see http://regexone.com/
';
my $regex = qr/./p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}