$re = '/./';
$str = '
For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression
For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/
For a gentle tutorial introduction to RegExes, see http://regexone.com/
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);