import Foundation
let pattern = #"."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression
For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/
For a gentle tutorial introduction to RegExes, see http://regexone.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}