package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.`)
var str = `
For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression
For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/
For a gentle tutorial introduction to RegExes, see http://regexone.com/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}