import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".";
final String string = "\n"
+ "For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression\n\n"
+ "For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/\n\n"
+ "For a gentle tutorial introduction to RegExes, see http://regexone.com/\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}