// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".").unwrap();
let string = "
For an explanatory overview of RegExes, see: http://en.wikipedia.org/wiki/Regular_expression
For an interactive tool that you can use to test and develop RegExes, see http://regex101.com/
For a gentle tutorial introduction to RegExes, see http://regexone.com/
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}