# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\(/$1$2$3$4$5$6function $3$7(/gm;t' <<< "this.foo = function() { // this.foo = function foo() {
something.foo : function() { // something.foo : function foo() {
window.foo = function() { // window.foo = function() {
this.foo[i] : function() { // this.foo[i] : function() {
var foo = function() { // var foo = function foo() {
foo: function() { // foo: function foo() {
foo :function() { // foo :function foo() {
foo:function() { // foo:function foo() {
foo : function() { // foo : function foo() {
foo = function() { // foo = function foo() {
foo = function () {} // foo = function foo () {}
foo = function() { // foo = function foo() {"