#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\("
Local $sString = "this.foo = function() { // this.foo = function foo() {" & @CRLF & _
"something.foo : function() { // something.foo : function foo() {" & @CRLF & _
"window.foo = function() { // window.foo = function() {" & @CRLF & _
"this.foo[i] : function() { // this.foo[i] : function() {" & @CRLF & _
"" & @CRLF & _
"var foo = function() { // var foo = function foo() {" & @CRLF & _
"" & @CRLF & _
"foo: function() { // foo: function foo() {" & @CRLF & _
"foo :function() { // foo :function foo() {" & @CRLF & _
"foo:function() { // foo:function foo() {" & @CRLF & _
"foo : function() { // foo : function foo() {" & @CRLF & _
"" & @CRLF & _
"foo = function() { // foo = function foo() {" & @CRLF & _
"" & @CRLF & _
"foo = function () {} // foo = function foo () {}" & @CRLF & _
"" & @CRLF & _
" foo = function() { // foo = function foo() {"
Local $sSubst = "$1$2$3$4$5$6function $3$7("
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)