import Foundation
let pattern = #"^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\("#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this.foo = function() { // this.foo = function foo() {
something.foo : function() { // something.foo : function foo() {
window.foo = function() { // window.foo = function() {
this.foo[i] : function() { // this.foo[i] : function() {
var foo = function() { // var foo = function foo() {
foo: function() { // foo: function foo() {
foo :function() { // foo :function foo() {
foo:function() { // foo:function foo() {
foo : function() { // foo : function foo() {
foo = function() { // foo = function foo() {
foo = function () {} // foo = function foo () {}
foo = function() { // foo = function foo() {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6function $3$7("#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)