use strict;
my $str = 'this.foo = function() { // this.foo = function foo() {
something.foo : function() { // something.foo : function foo() {
window.foo = function() { // window.foo = function() {
this.foo[i] : function() { // this.foo[i] : function() {
var foo = function() { // var foo = function foo() {
foo: function() { // foo: function foo() {
foo :function() { // foo :function foo() {
foo:function() { // foo:function foo() {
foo : function() { // foo : function foo() {
foo = function() { // foo = function foo() {
foo = function () {} // foo = function foo () {}
foo = function() { // foo = function foo() {';
my $regex = qr/^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\(/mp;
my $subst = '$1$2$3$4$5$6function $3$7(';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";