# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\("
test_str = ("this.foo = function() { // this.foo = function foo() {\n"
"something.foo : function() { // something.foo : function foo() {\n"
"window.foo = function() { // window.foo = function() {\n"
"this.foo[i] : function() { // this.foo[i] : function() {\n\n"
"var foo = function() { // var foo = function foo() {\n\n"
"foo: function() { // foo: function foo() {\n"
"foo :function() { // foo :function foo() {\n"
"foo:function() { // foo:function foo() {\n"
"foo : function() { // foo : function foo() {\n\n"
"foo = function() { // foo = function foo() {\n\n"
"foo = function () {} // foo = function foo () {}\n\n"
" foo = function() { // foo = function foo() {")
subst = "$1$2$3$4$5$6function $3$7("
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.