re = /^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\(/m
str = 'this.foo = function() { // this.foo = function foo() {
something.foo : function() { // something.foo : function foo() {
window.foo = function() { // window.foo = function() {
this.foo[i] : function() { // this.foo[i] : function() {
var foo = function() { // var foo = function foo() {
foo: function() { // foo: function foo() {
foo :function() { // foo :function foo() {
foo:function() { // foo:function foo() {
foo : function() { // foo : function foo() {
foo = function() { // foo = function foo() {
foo = function () {} // foo = function foo () {}
foo = function() { // foo = function foo() {'
subst = '$1$2$3$4$5$6function $3$7('
result = str.gsub(re, subst)
# Print the result of the substitution
puts result