const regex = /^(\s*)(?!window\.)(\w+\.)?(\w+)(\s*)([:=])(\s*)function(\s*)\(/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*)(?!window\\.)(\\w+\\.)?(\\w+)(\\s*)([:=])(\\s*)function(\\s*)\\(', 'gm')
const str = `this.foo = function() { // this.foo = function foo() {
something.foo : function() { // something.foo : function foo() {
window.foo = function() { // window.foo = function() {
this.foo[i] : function() { // this.foo[i] : function() {
var foo = function() { // var foo = function foo() {
foo: function() { // foo: function foo() {
foo :function() { // foo :function foo() {
foo:function() { // foo:function foo() {
foo : function() { // foo : function foo() {
foo = function() { // foo = function foo() {
foo = function () {} // foo = function foo () {}
foo = function() { // foo = function foo() {`;
const subst = `$1$2$3$4$5$6function $3$7(`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);