#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$"
Local $sString = "http://www.567890123456789782345hhhhhhhh67.comj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")