re = /^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$/
str = 'http://www.567890123456789782345hhhhhhhh67.comj'
# Print the match result
str.match(re) do |match|
puts match.to_s
end