using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$";
string input = @"http://www.567890123456789782345hhhhhhhh67.comj";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}