const regex = /^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{0,50}$)^(https?:\\\/\\\/)?[0-9A-Za-z-\\\\.@:%_\\+~#=]+\\.[a-zA-Z]{2,4}$', '')
const str = `http://www.567890123456789782345hhhhhhhh67.comj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}