import re
regex = re.compile(r"^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$")
test_str = "http://www.567890123456789782345hhhhhhhh67.comj"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")