$re = '/^(?=.{0,50}$)^(https?:\/\/)?[0-9A-Za-z-\\\\.@:%_\+~#=]+\.[a-zA-Z]{2,4}$/';
$str = 'http://www.567890123456789782345hhhhhhhh67.comj';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);