import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{0,50}$)^(https?:\\/\\/)?[0-9A-Za-z-\\\\.@:%_\\+~#=]+\\.[a-zA-Z]{2,4}$";
final String string = "http://www.567890123456789782345hhhhhhhh67.comj";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}