#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}"
Local $sString = "+4917643971069" & @CRLF & _
"+117643971069" & @CRLF & _
"00117643971069" & @CRLF & _
"004917643971069" & @CRLF & _
"017643971069"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")