import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}";
final String string = "+4917643971069\n"
+ "+117643971069\n"
+ "00117643971069\n"
+ "004917643971069\n"
+ "017643971069";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}