package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}`)
var str = `+4917643971069
+117643971069
00117643971069
004917643971069
017643971069`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}