const regex = /(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((\\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}', 'gm')
const str = `+4917643971069
+117643971069
00117643971069
004917643971069
017643971069`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}