using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}";
string input = @"+4917643971069
+117643971069
00117643971069
004917643971069
017643971069";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}