// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}").unwrap();
let string = "+4917643971069
+117643971069
00117643971069
004917643971069
017643971069";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}