$re = '/(((\+[0-9]{1,2})|0{1,2}[0-9]{2})|0{1})[0-9]{11}/m';
$str = '+4917643971069
+117643971069
00117643971069
004917643971069
017643971069';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);