import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=\"(.*)\"";
final String string = "<img src=\"http://kinoobzor.org/uploads/posts/2015-12/thumbs/1449526940-1892403274-1.jpg\" alt='Любите Куперов (2015)' title='Любите Куперов (2015)' />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}