import Foundation
let pattern = #"src="(.*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img src="http://kinoobzor.org/uploads/posts/2015-12/thumbs/1449526940-1892403274-1.jpg" alt='Любите Куперов (2015)' title='Любите Куперов (2015)' />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}