// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"src="(.*)""#).unwrap();
let string = "<img src=\"http://kinoobzor.org/uploads/posts/2015-12/thumbs/1449526940-1892403274-1.jpg\" alt='Любите Куперов (2015)' title='Любите Куперов (2015)' />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}