#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^a\n|\G(?<!\A))\n*\Kb$"
Local $sString = "b" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"b" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"b" & @CRLF & _
"b" & @CRLF & _
"a" & @CRLF & _
"c" & @CRLF & _
"b" & @CRLF & _
"a" & @CRLF & _
"b" & @CRLF & _
"a" & @CRLF & _
"c" & @CRLF & _
"c" & @CRLF & _
"d" & @CRLF & _
""
Local $sSubst = "c"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)