$re = '/(?:^a\n|\G(?<!\A))\n*\Kb$/m';
$str = 'b
a
b
b
c
b
a
b
b
b
a
c
b
a
b
a
c
c
d
';
$subst = "c";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;