re = /(?:^a\n|\G(?<!\A))\n*\Kb$/m
str = 'b
a
b
b
c
b
a
b
b
b
a
c
b
a
b
a
c
c
d
'
subst = 'c'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result