import re
regex = re.compile(r"(?:^a\n|\G(?<!\A))\n*\Kb$", flags=re.MULTILINE)
test_str = ("b\n"
"a\n"
"b\n"
"b\n"
"c\n"
"b\n"
"a\n"
"b\n"
"b\n"
"b\n"
"a\n"
"c\n"
"b\n"
"a\n"
"b\n"
"a\n"
"c\n"
"c\n"
"d\n")
subst = "c"
result = regex.sub(subst, test_str)
if result:
print(result)