using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:xxx|yyy)(,(?:xxx|yyy))*)$";
string input = @"xxx
yyy
xxx,xxx
yyy,xxx
xxx,yyy,yyy,yyy
But these would be invalid:
xx
yyyy
xxx,
xxxyyy
xxx,,yyy
,xxx,yyy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}